INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.




Unsere Partner:

DIAdem-Forum.de Partner

DIAdem-Forum.de Partner






Stellenangebote:
Big Data Scientist / Analyst (m/w) Messdatenmanagement
Ingolstadt

Projektmanager Visualisierung (m/w)
München, Fulda

Entwicklungsingenieur/-in im Bereich HV Energie-Bordnetz für Elektro- und Hybridfahrzeuge
Böblingen

Diplom-Ingenieur/-in Geoinformatik / Fernerkundungsdatenverwaltung
Frankfurt am Main

BI - Analyst (m/w)
Unterföhring bei München





.
 
Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5

Audio wiedergabe
02.12.2017, 01:41,
#1
DIAdem-Version: 15
DIAdem-Sprachversion: DE
DIAdem Erfahrung seit: 2010
Audio wiedergabe

Hallo,

Ich habe ein kleines Problem. Ich wollte gerne eine Audio Datei (.wav) in DIAdem automatisiert abspielen, wenn der Benutzer auf einen Button klickt. Ich lade bereits automatisiert .wav-Dateien und halte dann zunächst interaktiv an. Ich möchte nun gerne, das man sich die entsprechende Audio-Datei anhören kann. Momentan löse ich das Problem wie folgt:

Wavepfad = (MyFolders_35_ & "\" & "10s\" & "WP_" & ED_Standort_ & "_" & ED_Seriennr_ & "___" & Tag_STR_ &"."& Monat_STR_ &"."& Jahr_STR_ &"___"& Stunde_STR_ &"-"& Min_STR_ &"-"& Sek_STR_ & ".wav")

set programm = Createobject("Wscript.Shell")

programm.run """C:\Program Files (x86)\Windows Media Player\wmplayer.exe """ & Wavepfad

Es ist klar, das sich nun jedesmal der wmplayer auf windows öffnet und dann die Datei abspielt sobald das script ausgeführt wird. Seit kurzem funktioniert dies aber nicht mehr. Wahrscheinlich wegen Windows 10. Ich wollte nun gerne direkt aus DIAdem die Wave abspielen. Leider ist das wie in der Hilfe beschriebene "Lautsprecher-Symbol" im View-Fenster grau hinterlegt. (Also nicht aktivierbar) Ich kann zwar die "Play-Taste" in DIAdem-View drücken und die Wave spielt ab, jedoch erhalte ich keine Sound-Ausgabe. Muss man dafür noch irgendwie eine GPI o.ä. installieren?

Ich wäre um eine Antwort dankbar.

Grüße
Andreas



Angehängte Dateien Thumbnail(s)
   
Antworten


Gehe zu: